Page tree
Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 12 Next »

Setup Eclipse

A preinstalled eclipse can be found at our files server Software:/MacOSX/Software/Eclipse

Install Eclipse (3.3.2)

Download the Java EE edition. It must include WTP.

Subversive (Subversion Plugin)

Register the following URLs in Help / Software Updates

Maven integration

Register the following URLs in Help / Software Updates

JIRA integration

  • Check Mylyn Extras and select JIRA integration

Setup Project

Create New Project

Select New / Other (not Project) 

Select Maven checkout from SCM

Provide subversion URL

http://svn.magnolia.info/svn/magnolia/trunk 

Check if you got all the projects (the sub modules)

Create a Server

If not yet done create a server.

Deploy the Webapp project

Open Server Edit Pane

Doubleclick on the server item 

Disable publishing

Make sure that the option Serve modules without publishing is selected. This ensures that the classes are taken from the target directories. 

Known Poblems

Wrong maven version is used for dependency checks

If the project can't build because of the following message (printed in Maven Console)

[WARN] Rule 0: org.apache.maven.plugin.enforcer.RequireMavenVersion failed with message: Detected Maven Version: 2.1-SNAPSHOT is not in the allowed range [2.0.9,2.0.9].

The expected stack trace is:


You must add the following to your main project pom:


        <plugin>
          <groupId>org.apache.maven.plugins</groupId>
          <artifactId>maven-enforcer-plugin</artifactId>
          <version>1.0-alpha-3</version>
          <configuration>
            <skip>true</skip>
          </configuration>
        </plugin>

Then clean all projects

To ensure that everything is fine you have to check if magnolia-core/target/classes/mgnl-bean.properties exist.

  • No labels